Migrating to 2010

Jul 7, 2010 at 2:42 PM

First off, thanks for your work on these activities. I've had several projects that these have totally saved my bacon!

I'm contemplating doing the big upgrade for our site to Sharepoint Foundations 2010. I've run some simulations using VmWare and it looks like it's going to be a very worthwhile upgrade. I'll be using the database-attach method for the upgrade. What special considerations should I make to keep these activities intact on the site?

Regards,

Stephen Lloyd

Sep 20, 2010 at 12:28 PM

We also are in process of testing database-attach method upgrade to 2010 but depend of these workflow activities for some processes. However the setup process will not run as it doesn't detect WSS. Is it possible to use any of the activites on 2010?

Regards
Mark

Coordinator
Oct 1, 2010 at 4:14 PM

Have you tried to just deploy wsp file without using the intall utility?

Oct 6, 2010 at 12:55 PM

I have tried that and the solution deploys successfully, however as soon as a workflow is initiated it fails with a "System.NullReferenceException: Object reference not set to an instance of an object." error.

Oct 6, 2010 at 1:07 PM

I take back my previous statement...upon further review I forgot to set my outbound mail settings in my test environment. My test workflows appear to be working just fine after a database attach upgrade to 2010.

Oct 20, 2010 at 2:07 PM

No one is clear that this works in SharePoint 2010, so can I install this solution in 2010 then migrate my 2007 databases and everything should still work?

Nov 30, 2010 at 11:05 AM

I deployed the WSP manually to 2010 and after enabling it in the admin screens and IISRESET I can both see and use the custom workflows in Designer and deploy them. Initally I could see the workflow actions but not make them part of a workflow, but it is all working now. Thanks

Dec 17, 2010 at 9:44 AM

I have done a (test) migration to 2010 for a customer and deployed the WSP on the new server. At first the workflows were working fine. But when I opened SharePoint designer 2010 and published the existing workflow again, the workflow broke.

Status: Error Occured

Workflow history: 17/12/2010 10:07   Error   System Account    An error has occurred in Workflow

There are no entries in the SharePoint log or in the Servers event log. Is there a solution for this?

Dec 30, 2010 at 1:53 PM

Don't mind my previous post, it had nothing to do with the custom workflow steps after all.

The problem that occured was an error while using the Current Item ID in a calculation. There was an exception for not being able to convert a string to double.

Mar 9, 2011 at 11:15 AM

Here is what I have used to install the package in SPS 2010. I have tested the Start another workflow and it is working correctly:
stsadm -o addsolution -filename DP.Sharepoint.Workflow.wsp
stsadm -o deploysolution -name DP.Sharepoint.Workflow.wsp -allowgacdeployment -immediate -url <your site url>

Mar 26, 2011 at 10:57 PM

I did what sh_kamalh sugested. For me it didn't work.

I used some commands to retract and remove the solution (look at help on "stsadm -help retractsolution"  and "stsadm -help removesolution"). Then, I did someting a little different:

1) Use the command: stsadm -o addsolution -filename "<fullpath>\DP.Sharepoint.Workflow.wsp"
     Where <fullpath> is the complete path to the wsp file.

2) I opened Central Admin, selected form the left menu "System Settings" and the I clicked on "Manage Farm Solutions" link.
   This took me to a page that listed all my installed solutions. One of them was DP.Sharepoint.Workflow... and it stated that it was not deployed.
   On the toolbar there is a link that reads "Deploy solution"... so I selected the DP solution, and then clicked on the link.
   A new page opened where I could choose when and where to deploy the solution. Pretty straitforward.

3) After deployment through Central Admin.... I opened Sharepoint Designer 2010 and... voila!!! The actions where there!

Enjoy!

May 9, 2011 at 11:27 PM

This solution worked for me -- however broke Nintex.  Nintex workflows come up with an "Error retrieving config.xml".  Luckily retracting this solution makes Nintex work again.  Does anyone have any idea how to make the two co-exist?

Thanks,

Lester.

May 18, 2011 at 1:35 PM

I would dis-advise using the old school method and use the nice new ones from the powershell as follows

Add-SPSolution c:\code\UsefulSPDWorkflowActivities_0.5.0\DP.Sharepoint.Workflow.wsp

Install-SPSolution –Identity DP.Sharepoint.Workflow.wsp –WebApplication http://sp2010 -GACDeployment -Force

I used the -Force as sometimes it goes funny

If things go pear shaped:

Uninstall-SPSolution –Identity DP.Sharepoint.Workflow.wsp –WebApplication http://sp2010

Remove-SPSolution –Identity DP.Sharepoint.Workflow.wsp