User Lookup Help

Feb 15, 2008 at 2:18 PM
Just installed SPD activities, must say thank you for the effort and time spent.

However I'm having problems with User Lookup, tried

Lookup Description property for USERNAME....

and it fails with this error
"System.ArgumentOutOfRangeException: Specified argument was out of the range of valid values.
Parameter name: Property not found."

Any ideas?

Thank you
Feb 18, 2008 at 9:27 PM
There are several areas to check to correct this type of problem.

1. Make sure that description is mapped to a profile property in SSP.
2. If it is mapped then make sure that you have 'Replicable' checked on the profile property. This is what gets it in to the SharePoint Users list for your site collection.
3. Make sure that the property is actually being mapped. Check a user profile and check that description is populated in the property that you mapped it to. Also, check the SharePoint Users Lists on your site collection and make sure that it got replicated down. If the property info doesn't show up in either place then you need to get your SSP stuff ironed out. The activity won't work if the data isn't there.
4. When using the activity, case is also important. Make sure that your property lookup matches the profile spelling, not the AD spelling.

Finally, if the data is there and you still get an error then the particular profile you are pulling data for may be blank. I have noticed that an error still occurs if the data is blank. As long as there is data then the activity works great.

Hopefully this helps