Send Email Extended Issue with Sender Email Address

Feb 14, 2011 at 9:40 PM

I'm having an issue with the Send Email Extended and the Sender value. The exception "System.FormatException: The specified string is not in the form required for an e-mail" is recorderd with the workflow.

I've tried various email addresses and format and still can't figure out what I'm doing wrong. Is there any documentation for the correct format of the Sender parameter? Also, id there a way to just use the default email address configured for SharePoint Outgoing Email?

Thanks in advance

Jose Morató

11th Judicial Circuit of Florida

Miami, FL

Feb 18, 2011 at 1:37 PM

Hey Jose,

Are you following this format - sender@server.com?

Thanks!

Tom

Feb 18, 2011 at 2:36 PM

Thanks for the response...

Yes using correct email format

It actually works If I hardcode an email address or choose from the address book but does not when I select email sender or email from a SharePoint list. I even tried setting a workflow var to email sender or email from and then referencing that var but same issue occurs.

I also verified that that email sender/email from values were good and was able to verify this by including these in the body of the email and publishing the workflow that works (hard-coding my email address).

 

Thanks ~ Jose

 

Feb 18, 2011 at 3:22 PM
Edited Feb 18, 2011 at 3:27 PM

Here's a link to image of the email I get if I hardcode an email as the sender, SharePoint Designer workflow and email config.

The image of the email received has 2 recipients in the To line. One is the hardcode email to make the workflow work and trhe other is the same workflow variable which the body shows the value correctly but the To line adds html tags?

Link to SkyDrive images

Jose

Jul 13, 2011 at 12:53 AM
Edited Jul 13, 2011 at 9:08 PM

"Also, id there a way to just use the default email address configured for SharePoint Outgoing Email?"

Isn't that what the out-of-box Send Email does?