Unable to install SD custom workflow activities

Jun 23, 2009 at 11:25 AM

downloaded the file, copied it onto the server. ran the exe using our farm admin account (the one i normally use to deploy solutions).  setup runs through the server requirements, which it passes.

you now get the option to select which web apps to install to. first issue - i can only select / deselect the central admin web app. all other web apps are pre selected and grayed out. This did not happen when i tested on my development server. click ok to continue and it starts to install, then get the following message


CodePlex.SharePointInstaller.InstallException: MOSSServer : http://MOSSServer : Default Web Site : Error: The web.config is invalid on this IIS Web Site: c:\inetpub\wwwroot\web.config. It then roles back the installation. this is a MOSS 32bit install.

 

tried to deploy using stsadm - message can back saying it had invalid tags???

 

can anyone help

Jun 3, 2010 at 9:28 PM
Edited Jun 3, 2010 at 9:28 PM

I am getting the same exact error during the install: " Error: The web.config is invalid on this IIS Web Site:".. the installer then does a roll back.

 

Does anybody know the solution to this?

 

Thanks.

Jun 3, 2010 at 9:42 PM

I found a work around... you can modify the setup.exe.config file.  Set the key "RequireDeploymentToAllContentWebAppliactions" to "false" instead of "true".  You can then select which web apps to install to.  I unchecked the web app that was causing the error above, and that fixed the issue.  I was able to successfully install. 

Nov 29, 2010 at 11:15 AM
Edited Nov 29, 2010 at 11:16 AM

Hi.

Did someone find a fix for this error??

santhanamk, the web app that is causing the error is the same that i need to deploy the workflow, so I can't remove it.

Can someone help us?

Tks