Problem creating any type of e-mail action

Jan 12, 2008 at 2:19 AM

I installed these custom activities on my test server without any problems at all. Then we installed them on the production system and now I can not create workflows with an e-mail action. Even the OOTB e-mail action from MS does not work. I opened a workflow that already contained an e-mail action and that workflow validated with no problem. It is just new workflows that will not work with an e-mail action. It highlights the 'to' portion as the part that has an error.

I'm not sure if this has anything to do with the actions that we just installed on production, but I know that the problem did not exist before. In fact, on my test system I set up a workflow that looks up a user property and then sends an e-mail and it worked fine. So I know the e-mail worked after installing this on my test machine. Now we installed it on the farm and the e-mail is broken.

The installation on the farm was not quite as smooth as on test. It installed fine, I activated the feature, and the activities showed up in SP Designer, but when I would select an activity then nothing would show up in the sentence area. I see that other have had the problem but I did everything recommended without any luck. On the server I ended up activating the feature on every site (such as mysite) and then SP Designer (on my local machine) had an error and shut itself down. After I started it back up then the sentence would appear after selecting the action.

Does anyone have an idea as to what the problem could be? I know the chan of events is confusing. It doesn't make much sense to me and I was the one doing it. I have also rebooted my laptop and that didn't help either.

Jan 14, 2008 at 8:54 AM

I have a similar problem.
I have used the e-mail action for some time. And it worked fine.
Last week I created some new workflows for some new lists (same workflow actions as I used in my earlier workflows)
For the new worksflows I got an error ( fail on the "to" field or on the "Subject" field)
The old workflows still working fine. I have tried to reboot the server.
I haven't installed WSS SP1

Any ideas ?

Jan 14, 2008 at 3:59 PM
I noticed that there is one point I left out in my first post as well. I installed the activities on test and everything worked great. Then I installed the activities on production and then the e-mail action was broken for new workflows on production and test. That seems odd. I don't know why an activity install on production would break the out of the box e-mail activity on test. It must have had something to do with SP Designer since designer must communicate with the server to pick up the activities.

I eventually got it to work. I deactivated the custom activities on my test machine and e-mail was still broken. Then I deactivated custom activities on produciton and e-mail was not broken anymore. I reactivated on test and e-mail was still fine and the custom activities worked. I reactivated on production and so far things seem to be ok. Maybe I activted the custom activity before all of the servers recognized it or something. I have no idea, but it seems to be working.

brigjevi, try deactivating and reactivating the feature. Maybe that will help.