Error with workflows since installed SPD activities

Feb 8, 2008 at 12:15 PM

Since I have installed this add-in I now have a problem. Whenever a user tries to upload a new document to a library where a workflow is set to run on document upload, it returns a 'an unexpected error has occured.....' message although it appears that the document was uploaded successfully when you go back to the document library. If I change the workflow to run manually, documents can be uploaded without the error message appearing. Has anyone else had this issue?

Also I tried to uninstall the add-in to see if that would fix the issue but when I uninstall it and I try to edit or create a workflow in Sharepoint designer i get this error message:
"Errors were found when compiling the workflow.The workflow files were saved but cannot be run."
"Unexpected error on server associating the workflow"

Can someone help me fix either of these issues? I've searched on google for a fix to the second issue but all the fixes I've tried haven't worked.

Thanks in advance.

Feb 11, 2008 at 4:13 PM
What custom action were you using?
Feb 12, 2008 at 8:06 AM
I'm not using one of the custom actions. The workflow just sends an email to a user or group of users to tell them a document has been uploaded. The error doesn't occur if the documents don't have to be checked out for editing, or if I change the workflow to run manually and not automatically when a document is created.

Really stumped on this one. If I could uninstall the add-in completely I could check to see if that's actually what's causing the problem (it could just be coincidence that I started getting the error at the same time I intalled the add-in) but uninstalling it gives be the second error metioned in my 1st post.

Thaks for trying to help.

Dec 8, 2008 at 7:21 PM
I'm having the same problem as mekonj above.  At this point in time no workflows are functioning on my site due to to this error.  I need a solution.

Jan 30, 2009 at 12:25 AM
After comparing web.config files I found some differences between a working web app and the web app with a broken SPD workflow (had the same error you mention above).

I opened the web.config file and removed two lines in <System.Workflow.ComponentModel.WorkflowCompiler> sectino that started with "System.Workflow.DP".  Then I did the usual IISReset command and I was back to normal. 

I think I must of acquired these two assemblies from something I uploaded a while back.  Unfortunately the uninstall didn't remove the reference from my web.config.  I feel lucky to have found the problem under 2 hours. 

Hope this helps someone out there.