in not working with SP 2013

Jan 24, 2013 at 1:51 PM
Edited Jan 24, 2013 at 1:51 PM

Guys, activities are in workflow action menu in SPD 2013, but i cannot add them, nothing happenes when i try to add them in workflow. Am i doing something wrong or solution is not working in SP 2013?

Thanks

Jan 31, 2013 at 6:52 PM
I'm having similar issues. Updating 2010 db to 2013. Workflows come over, but these actions come in with an Error: Could not deserialize object. The type 'DP.Sharepoint.Workflow.StartAnotherWorkflow' could not be resolved. The actions appear in SPD2013 under Actions, but when I try to replace, the workflow errors on compiling: 'The type or namespace name 'DP' could not be found (are you missing a using directive or an assembly reference.'

If anyone has gotten these to work...I would sure appreciate the fix!

Thanks!
Mar 22, 2013 at 4:28 PM
Dear rcourchane,

Do you find any resolution to the problem. I would really appreciate your help.
Mar 24, 2013 at 5:01 PM
Dear All

First of all you need to deploy the custom action solutions using -CompatibilityLevel {14, 15} as a parameter of Install-SPSolution

Secondly you need to add AuthorizedType for custom actions entry in <System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> <targetFx version="v4.0"> as well as in <System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> in web.config
May 9, 2013 at 4:35 PM
shahabjuman2012 wrote:
Secondly you need to add AuthorizedType for custom actions entry in <System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> <targetFx version="v4.0"> as well as in <System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> in web.config
Can you provide more details as it relates to what changes are required:
<System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> <targetFx version="v4.0"> as well as in <System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> in web.config
Jul 5, 2013 at 2:40 PM
Edited Jul 5, 2013 at 2:44 PM
This one worked for me - by editing the web.config file after Shahajuman's first step


<targetFx version="v4.0">
<authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
<authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
<authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
</targetFx>
Sep 4, 2013 at 5:34 PM
jjeugene, I tried adding what you posted, it didn't work and I just realized all 3 lines are exactly the same...

Which exact locations do we add the 3 lines to? I have added it to

System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes>

and

<System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> <targetFx version="v4.0">

How many locations are there? 3? Do you need to add safe controls as well?

I would appreciate any help with this, thanks.
  • Lucas
Sep 19, 2013 at 8:53 AM
Edited Sep 19, 2013 at 8:55 AM
update
Sep 19, 2013 at 8:54 AM
l2chiu wrote:
jjeugene, I tried adding what you posted, it didn't work and I just realized all 3 lines are exactly the same...

Which exact locations do we add the 3 lines to? I have added it to

System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes>

and

<System.Workflow.ComponentModel.WorkflowCompiler> <authorizedTypes> <targetFx version="v4.0">

How many locations are there? 3? Do you need to add safe controls as well?

I would appreciate any help with this, thanks.
  • Lucas
Try this Lucas

</targetFx>
 <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />

</authorizedTypes>
Oct 8, 2013 at 8:27 PM
Edited Oct 8, 2013 at 8:31 PM
I, too am trying to deploy this on SP2013 Farm. I have done the following:

BACKUP:
C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\CONFIG\web.config as web.old
 
POWERSHELL:
Add-spsolution -literalpath c:\wsp\dp.sharepoint.workflow.wsp
---- then
install-spsolution -identity dp.sharepoint.workflow.wsp -AllWebApplications -GACDeployment -CompatibilityLevel 15
 
Then Edit Web.config
Edit C:\Program Files\Common Files\microsoft shared\Web Server Extensions\15\CONFIG\web.config:
 
<System.Workflow.ComponentModel.WorkflowCompiler>
  <athorizedTypes>
          <targetFx>
      ...
      ...
      ...
                <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral,   PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
         </targetFx>
                <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
       </authorizedTypes>
</System.Workflow.ComponentModel.WorkflowCompiler>
When I open SP Designer 2013, edit my workflow, and try to insert one of the custom actions that are listed, nothing happens. Has anyone found a truly workable solution for this? Have I missed something?
Oct 25, 2013 at 2:45 PM
Edited Oct 25, 2013 at 2:46 PM
Hello ac_johnson,

Below are the changes I added. The safe controls are all different, take a note of the NameSpace. For AuthorizedTypes, they look exactly the same, all 3 lines. I had copied this from my SharePoint 2010 environment and I figured if it worked there, it should work for SharePoint 2013. Also, I made my changes at the IIS directory of my web application, bolded below and not in the 15 hive config directory.

C:\inetpub\wwwroot\wss\VirtualDirectories\80

<SafeControls>
 ...
   <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.InfoPath" TypeName="*" Safe="True" SafeAgainstScript="False" />
  <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.Install" TypeName="*" Safe="True" SafeAgainstScript="False" />
  <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Safe="True" SafeAgainstScript="False" />
...
</SafeControlls>

AND

<System.Workflow.ComponentModel.WorkflowCompiler>
<authorizedTypes>
      <targetFx version="v4.0">
  ...
  ...
  ...
            <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
    <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
    <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />

      </targetFx>
</authorizedTypes>
</System.Workflow.ComponentModel.WorkflowCompiler>
Oct 25, 2013 at 4:32 PM
Thank you so much, 12cjiu!
That worked perfectly! So relieved to have this resolved.
Mar 21, 2014 at 4:39 AM
Edited Mar 21, 2014 at 4:44 AM
At my attempt of trying this... I was able to get it successfully working without having to modify any Web.config files.

I simply just run the powershell commands and rebooted the server... After the reboot I was able to get them into my workflow and run them without any issues.

I recall trying to use them before the reboot and I was getting errors.. So maybe reboot was key?

I'm running...
Windows Server 2012 R2 / Sharepoint 2013 SP1
Using 2010 Workflows

POWERSHELL:
Add-spsolution -literalpath c:\wsp\dp.sharepoint.workflow.wsp
---- then
install-spsolution -identity dp.sharepoint.workflow.wsp -AllWebApplications -GACDeployment -CompatibilityLevel 15
Dec 22, 2014 at 7:39 PM
I can confirm this does work on Sharepoint 2013. Along with what everyone has posted in this thread, i had to run the following command to enable declartive workflows.
stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes
Aug 18, 2015 at 11:36 PM
Hello, I have added the wsp, added the lines to webconfig. ran stsadm this still is not working. Could not deserialize object. The type 'DP.Sharepoint.Workflow.SendEmailExtended' could not be resolved. And I an unable to add the actions to workflows in SPD 2013. Please advise. We have migrated from 2010 to 2013 and will be going live next week.
Aug 20, 2015 at 9:38 AM
Edited Aug 20, 2015 at 9:38 AM
@reedwaters
See step 4 in the installation instruction: If you have a non-english installation of sharepoint, you need to copy DPWorkflow.ACTIONS from [SP HiVE]\TEMPLATE\1033\Workflow to [SP HiVE]\TEMPLATE\"YOUR LCID"\Workflow
Aug 20, 2015 at 9:49 AM
We've added en deployed the .wsp, edit the web.config, copied DPWorkflow.actions and so on. Now we can add the custom workflow tasks in SP2013. Many thanks for that!
But after migration from SP2010 to SP2013 (both foundation) the existing workflows with the custom tasks in it keep saying: Could not deserialize object. The type 'DP.Sharepoint.Workflow.SendEmailExtended' could not be resolved.
Now I'll have to rewrite all of my workflows with the custom tasks in it (>150). Is there a better way to do this?
I added en deployed the .wsp before mounting and upgrading the content database.

Thank you in advance!
Aug 20, 2015 at 6:55 PM
Edited Aug 20, 2015 at 6:55 PM
@Atema, the dpworkflow.Actions is in the Hives. Any other suggestions? I have an english installation of sharepoint.
Aug 21, 2015 at 6:15 AM
@reedwaters
Maybe start all over.
This how it works for me:
  • Add-SPSolution -LiteralPath c:\DP.Sharepoint.Workflow.wsp
  • install-spsolution -identity dp.sharepoint.workflow.wsp -AllWebApplications -GACDeployment -CompatibilityLevel 15 -force
  • Backup C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config
  • Open C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config
  • Replace under <SafeControls> the three lines with assembly="DP.Sharepoint.Workflow, with these three lines:
    <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.InfoPath" TypeName="*" Safe="True" SafeAgainstScript="False" />
    <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.Install" TypeName="*" Safe="True" SafeAgainstScript="False" />
    <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Safe="True" SafeAgainstScript="False" />
  • Add under <authorizedTypes>
    <targetFx version="v4.0">
    these three lines:
<authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
        <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
            <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
  • Run IISRESET
  • Optional: Reboot server
Only problem I have is that after the migration from SP2010 to SP2013 (both foundation) the existing workflows with the custom tasks in it keep saying: Could not deserialize object. The type 'DP.Sharepoint.Workflow.SendEmailExtended' could not be resolved.
But I can add the custom tasks in the workflows
Aug 21, 2015 at 7:56 PM
Hello thanks. I have done all of this and confirmed that these are in the correct location in the web.config. The actions are available in the drop down but I am not able to add the actions in the workflows. yes I get the same error on existing flows with these custom actions. Any other advise??
Oct 26, 2015 at 12:35 AM
Hi All,

have done the following,

• Add-SPSolution -LiteralPath c:\DP.Sharepoint.Workflow.wsp
• install-spsolution -identity dp.sharepoint.workflow.wsp -AllWebApplications -GACDeployment -CompatibilityLevel 15 –force

• stsadm.exe –o setproperty –propertyname declarativeworkflowautostartonemailenabled –propertyvalue yes

• Backup C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config
• Open C:\inetpub\wwwroot\wss\VirtualDirectories\80\web.config
• Replace under <SafeControls> the three lines with assembly="DP.Sharepoint.Workflow, with these three lines:
    <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.InfoPath" TypeName="*" Safe="True" SafeAgainstScript="False" />
    <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow.Install" TypeName="*" Safe="True" SafeAgainstScript="False" />
    <SafeControl Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Safe="True" SafeAgainstScript="False" />
• Add under <authorizedTypes>
    <targetFx version="v4.0">
     these three lines:
<authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
        <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
            <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
• Run IISRESET
• Reboot server
  • Activated the feature
created the custom workflow but when I tries to publish it Ill get below error even though im able to save the workflow and there is no error in it.

"(0, 10) The type or namespace name 'DP' could not be found (are you missing a using directive or an assembly reference?))
(30, 16) The type or namespace name 'DP' could not be found (are you missing a using directive or an assembly reference?))"

any help would be highly appreciated. thanks in advance!
Oct 26, 2015 at 6:21 PM
Hello All,

Im able to fix the issue, have added the below codes only on <authorizedTypes> and when I add these 3 lines in <targetFx version="v4.0"> it started working and able to publish the workflow. thanks all for this wonderful code.
<authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
        <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
            <authorizedType Assembly="DP.Sharepoint.Workflow, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0298457208daed83" Namespace="DP.Sharepoint.Workflow" TypeName="*" Authorized="True" />
Feb 17, 2016 at 7:10 AM
I've done all you mentioned
its deployed successfully, but in Site Collection Features there is no new switch to activate and in SharePoint Designer there is no new activity. Any advise?
Mar 3, 2016 at 8:28 PM
Even though there is no activation entry in the Site Collection Features, the extended workflow pieces are available in SPD.