Dreadful Failed On Start (Retrying) from Copy List Item Extended activity

May 29, 2009 at 2:15 PM

Hi all,

I downloaded the latest source code (August, 2008) of Custom Workflow Activities, and I still get the same issues.

I have been trying almost a month over this Copy Item Extended activity.

I have tried virtually anything and everything, but these following two issues never go away.

1) Sometimes, the workflow does not begin automatically.  Sometimes, it does.  No idea how and why this is the case.

2) Workflow always fails with Failed On Start (Retrying) message.

Can somebody please tell me how I am supposed to fix this problem?

It would be a tremendous help to me.

Thank you so much in advance.

Jun 4, 2009 at 12:51 PM

I am having the same problems after installing this solution. I get "Failed on start(retrying)" error on all SPD worflows. Even the ones that used to work before and don't use any new activities.


Any help is much appreciated.

Thanks in advance.

Jun 4, 2009 at 12:54 PM

I just want to point out that you should have your environments updated to the latest Service Packs and the like. All of these worked wonderfully in my test environment and I am pushing the request to move these to production. I am happy with them all. No problems here!

Jun 4, 2009 at 3:11 PM

Thanks for your reply Wartickler.

All of these worked wonderfully in my test environment, too.

It started to fail when I moved it to production.

Production servers do not have the latest service packs and the like due to the administration issues, but it is not like production servers are equipped with extremely old patches only. 

and I wish you could tell me something more specific than "service packs and the like".

Do these activity require any specific version of service pack or .NET Framework or anything like that?  (I do not see why such factors would matter so much for a workflow activity by the way)

Can the author of these activities clarify this?

Thanks again, guys