Install Sharepoint Designer Custom Workflow

Jan 21, 2010 at 12:38 PM

Hello,

I plan to install this on our farm, but...

Do i really need to install to all web applications ?

I can see this settings in setup.exe.config:

<add key="RequireDeploymentToAllContentWebApplications" value="true"/>

Feb 16, 2010 at 10:26 PM

Did you ever figure this out?  We're about to install this solution on our farm, and are wondering whether we need to run setup.exe on each WFE/App server.

Feb 17, 2010 at 9:15 AM

Not yet. Still waiting for an answer from the guys who knows everything. :o)

Nov 29, 2010 at 2:04 PM

Hi jakobdo.

rsrs, I really don't know everything ;) , but I changed this parameter and was able to install  to just one web app

<add key="RequireDeploymentToAllContentWebApplications" value="false"/>

Actually I have another problem. I need to deploy it to a web app that I'm receiving the following error during installation:

***** SOLUTION DEPLOYMENT *****
MY_SERVER_NAME : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.

MY_SERVER_NAME2 : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.


***** ERROR *****
MY_SERVER_NAME : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.

MY_SERVER_NAME2 : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.


CodePlex.SharePointInstaller.InstallException: MY_SERVER_NAME : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.

MY_SERVER_NAME2 : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.

 ---> CodePlex.SharePointInstaller.InstallException: MY_SERVER_NAME : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.

MY_SERVER_NAME2 : http://my_url_name/ : Default Web Site : Error: The web.config is missing from this IIS Web Site: c:\inetpub\wwwroot\web.config.


   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()
   --- End of inner exception stack trace ---
   at CodePlex.SharePointInstaller.InstallProcessControl.WaitForJobCompletionCommand.Execute()
   at CodePlex.SharePointInstaller.InstallProcessControl.TimerEventInstall(Object myObject, EventArgs myEventArgs)
***** SOLUTION RETRACTION *****
MY_SERVER_NAME : http://my_url_name/ : The solution was successfully retracted.
MY_SERVER_NAME2 : http://my_url_name/ : The solution was successfully retracted. 

 

Can someone help me?